Docs‎ > ‎Architecture‎ > ‎

Platform Support

This page describes what versions of miscellaneous software is compatible with the current release of Espresso Logic.

  • Tested with means that Espresso Logic has tested these platforms and will provide full support.
  • Compatible with means that Espresso Logic has not fully tested these platforms (other than the ones in the Tested with list, of course), but believes that they should work fine. If any problem is encountered, Espresso Logic will make a best effort to provide support.


Operating system

Tested with:

  • Windows 7
  • Windows 8
  • Windows Server 2008
  • Windows Server 2012
  • Mac OSX 10.10
  • CentOS Linux 6.7
  • Amazon Linux 3.14
  • Red Hat Enterprise Linux 7.1

Compatible with:

  • Windows 7 and above
  • Mac OSX 10 and above
  • All versions of Linux 3.x and above
  • Most platforms that support JDK 1.7 should work


Java

Tested with:

  • JDK 1.7.0
  • JDK 1.8.0

Compatible with:

  • JDK 1.7 and above
  • JDK 1.6 and earlier are no longer supported


Java containers

Tested with:

  • Tomcat 7 and 8
  • Jetty 8
  • Glassfish 4.0

Compatible with:

  • Tomcat 7 and higher
  • Jetty 7 and higher
  • Glassfish 3.0 and higher
  • WebSphere 7.0 and higher
  • WebLogic 11g and higher
  • JBoss 6.0 and later

Databases

Tested with:

  • MySQL 5.6.19, 5.6.20, 5.6.21
  • Oracle 11.2
  • Microsoft SQL Server 2012 (aka 11.0)
  • PostgreSQL 9.4
  • NuoDB 2.1, 2.2
  • Vertica 7.1

Compatible with:

  • MySQL 5.5 and higher, except for admin DB which requires MySQL 5.6.4 or higher
  • Oracle 9 and higher
  • Microsoft SQL Server 2005 and higher
  • PostgreSQL 9.0 and higher
  • NuoDB 2.0 and higher
  • Vertica 7.0 and higher


Drivers

Tested with:

  • MySQL JDBC 5.1.26
  • Oracle JDBC 12.1
  • Microsoft SQL Server JDBC 4.0
  • PostgreSQL JDBC 9.4
  • NuoDB JDBC 1.0
  • Vertica JDBC 7.1

Compatible with:

  • MySQL JDBC 5.1 and higher
  • Oracle JDBC 10 and higher
  • Microsoft SQL Server JDBC 4.0 and higher
  • PostgreSQL JDBC 9.0 and higher
  • NuoDB JDBC 1.0 and higher
  • Vertica JDBC 7.0 and higher